Cameo Systems Modeler 18.5: Java Error

Discussions about Java virtual machine, installation, and running

Moderator: Moderators

Cameo Systems Modeler 18.5: Java Error

Postby cg7aa » Thu Jun 15, 2017 7:21 am

Hi,

I'm not sure if this is the right forum for my question so please forgive me if it's not; I'm trying to follow the web tutorial here: https://www.youtube.com/watch?v=9RFKoTUiQ60

Whenever I execute the timer simulation I get the following error messages:

00:00:00,000 : **** Activity Tick is initialized. ****
00:00:00,000 : **** Activity Tick is started! ****
00:00:00,939 ERROR: Cannot evaluate Opaque Action: org.mozilla.javascript.EcmaError: ReferenceError: "time" is not defined. (<Unknown source>#1) in <Unknown source> at line number 1 expression body: time = time+1 00:00:01,248 : **** Activity Tick execution is terminated. ****

Any help would be greatly appreciated. I've already experimented with changing the location of Java in the properties file and I can't find any solutions online.

Regards
Dan
cg7aa
Forum Newbie
Forum Newbie
 
Posts: 2
Posts Rating:0
Joined: Wed Jun 14, 2017 8:20 pm

Re: Cameo Systems Modeler 18.5: Java Error

Postby arnon_l » Sun Jun 18, 2017 8:32 pm

Dan,

Please make sure that "time" property has been defined in your model.

Or you can send me the model to check.

Regards,
arnon_l
Customer Support
Customer Support
 
Posts: 78
Posts Rating:9
Joined: Thu Aug 30, 2012 3:39 am

Re: Cameo Systems Modeler 18.5: Java Error

Postby piccolocanadesevolante@gmail.com » Tue Jun 20, 2017 2:40 pm

arnon_l wrote:Dan,

Please make sure that "time" property has been defined in your model.

Or you can send me the model to check.

Regards,


Thanks very much for your offer to help. I've attached the file. I defined time as demonstrated in the youtube tutorial, maybe I made a mistake in the definition.
You do not have the required permissions to view the files attached to this post.
piccolocanadesevolante@gmail.com
Forum Newbie
Forum Newbie
 
Posts: 10
Posts Rating:0
Joined: Tue Jun 20, 2017 2:33 pm

Re: Cameo Systems Modeler 18.5: Java Error

Postby piccolocanadesevolante@gmail.com » Wed Jun 28, 2017 9:31 am

Problem solved; it seems the value property 'time' was in the wrong part of the containment tree.
piccolocanadesevolante@gmail.com
Forum Newbie
Forum Newbie
 
Posts: 10
Posts Rating:0
Joined: Tue Jun 20, 2017 2:33 pm


Return to Installing and running

Who is online

Users browsing this forum: No registered users and 0 guests