Doors Import Problem Filtering Empty Requirement Blocks

Discussions about systems engineering product SysML functionalities

Moderator: Moderators

Doors Import Problem Filtering Empty Requirement Blocks

Postby mustafaA » Wed Feb 21, 2018 5:12 am

Hi,
I have requirements imported from doors. Some have empty text fields (others have filled text fields). I want to filter out requirements with empty text fields and display others in a requirement diagram, so I can relate those reqs have filled text fields with blocks etc. I have tried smart packages but I was not able to do. I have expected to have Excel-like filter at requirement table but I guess this is not the case.

Cameo 18.5 SP3.

Further Details:
I understand that the technique we use for doors for requirements is a little bit different from what it is intended. To achieve a nice export to MS Word, we use an object like a header for a set of requirement. When I import to Cameo following issues occur:
Objects that are used as headers have an ID number, a name but text fields are empty.
The real requirement objects have an ID and filled text fields without requirement name.
mustafaA
Forum Newbie
Forum Newbie
 
Posts: 11
Posts Rating:0
Joined: Thu Feb 02, 2017 1:06 am

Re: Doors Import Problem Filtering Empty Requirement Blocks

Postby supatp » Mon Mar 05, 2018 4:41 am

Hello mustafaA,

Out of the box, DataHub provide a mapping template from DOORS Object to Requirement.
And 3 properties mapped from DOORS Object -> SysML Requirement:
- Object Heading -> Name
- Object Id -> ID
- Object Text -> Text

Basically DOORS Object is generic, DataHub cannot identify whether it's Heading or Content object. It's just an object with Heading value or not.
So, that's why Heading Object was imported as Requirement with Name. And Content object don't have name because Object Heading attribute has no value.

You may edit the mapping for the imported data vie menu Tools> DataHub> Schema Map Manager.

Or if you want DataHub to ask for the mapping every time you bringing in the data, you may set an option from menu Options> Environment> Cameo DataHub section. Then change the Mapping Policy option to Always show the mapping dialog.

Best Regards,
Supat P.
supatp
Customer Support
Customer Support
 
Posts: 165
Posts Rating:11
Joined: Mon Feb 08, 2010 2:45 am


Return to SysML

Who is online

Users browsing this forum: No registered users and 0 guests