integration problems with Eclipse 2 (MR5) and MD5.5

Discussions about integrations with other 3th party tools

Moderator: Moderators

integration problems with Eclipse 2 (MR5) and MD5.5

Postby Andrew McVeigh » Wed May 15, 2002 6:31 am

Hi,

I tried to integrate Eclipse 2.0 (MR5?) which is the current stable build of 2.0. I got the following error when I tried to "update UML model" from Eclipse. It seems that the TypeInfoRequestor class has moved to the corext package in the newer version of the jdt.ui plugin. Any ideas about how to get around this?

Cheers,
Andrew McVeigh,
London, UK



You do not have the required permissions to view the files attached to this post.
Andrew McVeigh
 
Posts Rating:

Re: integration problems with Eclipse 2 (MR5) and MD5.5

Postby Mindaugas Ringys » Thu May 16, 2002 4:49 am

Hi Andrew,

It seems that MagicDraw 5.5 beta will not integrate with this Eclipse version. Please use earlier version of Eclipse 2.0. We did testing with build 2002-01-25

We will fix this problem in final 5.5 version.

Thanks for the feedback.

--

Mindaugas Ringys
Project Leader
No Magic Lithuanian Development Center
Gedimino g. 47- 408, 3000 Kaunas, Lithuania
P.O. box 2166, LT- 3000, Kaunas, Lithuania
Phone: +370 37 324032 Fax: +370 37 320670
e-mail : mindis
WWW: http://www.nomagic.com
--
OO software design can be an appealing challenge if you have
the best UML modeling tool: http://www.magicdraw.com
"Andrew McVeigh" <andrewmcveigh> wrote in message news:abtju9$map$1...
Hi,

I tried to integrate Eclipse 2.0 (MR5?) which is the current stable build of 2.0. I got the following error when I tried to "update UML model" from Eclipse. It seems that the TypeInfoRequestor class has moved to the corext package in the newer version of the jdt.ui plugin. Any ideas about how to get around this?

Cheers,
Andrew McVeigh,
London, UK



You do not have the required permissions to view the files attached to this post.
Mindaugas Ringys
 
Posts Rating:

Re: integration problems with Eclipse 2 (MR5) and MD5.5

Postby Christian Groove » Mon Jun 10, 2002 9:18 pm

Hi

i am not completly sure, iff M5 is a real 2.0 version.
Besides it was not stable so i decided to load F2, that
works better.

But i have no idea how to activate one applicatation
by the other one. No idea, how this may work, maybe
one code-engeneering set may talk to eclipse......

Andrew McVeigh wrote:

> Hi,
>
> I tried to integrate Eclipse 2.0 (MR5?) which is the current stable build
> of 2.0. I got the following error when I tried to "update UML model" from
> Eclipse. It seems that the TypeInfoRequestor class has moved to the
> corext package in the newer version of the jdt.ui plugin. Any ideas about
> how to get around this?
>
> Cheers,
> Andrew McVeigh,
> London, UK

You do not have the required permissions to view the files attached to this post.
Christian Groove
 
Posts Rating:

Re: integration problems with Eclipse 2 (MR5) and MD5.5

Postby Mindaugas Ringys » Tue Jun 11, 2002 9:49 am

Hi Christian,

I am afraid that MagicDraw 5.5 does not work well with latest Eclipse build.
Integration was done with February Eclipse build. Some classes were changed
in Eclipse API and this causes the problems.

Final MagicDraw 5.5 will come at the end of this month. It will integrate
with latest Eclipse build without problems.

--
Mindaugas Ringys
Project Leader
No Magic Lithuanian Development Center
Gedimino g. 47- 408, 3000 Kaunas, Lithuania
P.O. box 2166, LT- 3000, Kaunas, Lithuania
Phone: +370 37 324032 Fax: +370 37 320670
e-mail : mindis
WWW: http://www.nomagic.com
--
OO software design can be an appealing challenge if you have
the best UML modeling tool: http://www.magicdraw.com
"Christian Groove" <christian.groove> wrote in message
news:ae3qu0$1l1$1...
> Hi
>
> i am not completly sure, iff M5 is a real 2.0 version.
> Besides it was not stable so i decided to load F2, that
> works better.
>
> But i have no idea how to activate one applicatation
> by the other one. No idea, how this may work, maybe
> one code-engeneering set may talk to eclipse......
>
> Andrew McVeigh wrote:
>
> > Hi,
> >
> > I tried to integrate Eclipse 2.0 (MR5?) which is the current stable
build
> > of 2.0. I got the following error when I tried to "update UML model"
from
> > Eclipse. It seems that the TypeInfoRequestor class has moved to the
> > corext package in the newer version of the jdt.ui plugin. Any ideas
about
> > how to get around this?
> >
> > Cheers,
> > Andrew McVeigh,
> > London, UK
>


You do not have the required permissions to view the files attached to this post.
Mindaugas Ringys
 
Posts Rating:

Re: integration problems with Eclipse 2 (MR5) and MD5.5

Postby Christian Groove » Tue Jun 11, 2002 9:10 pm

Mindaugas Ringys wrote:

> Hi Christian,
>
> I am afraid that MagicDraw 5.5 does not work well with latest Eclipse
> build. Integration was done with February Eclipse build. Some classes were

That's a pity !


> changed in Eclipse API and this causes the problems.
>
> Final MagicDraw 5.5 will come at the end of this month. It will integrate
> with latest Eclipse build without problems.


That sounds good. Actually i have no idea how this could work.
Could you summarize, how this will support the JAVA/C++ development ?
Does the integration look like a code-engeneering set, where the
spec from Magic-Draw will be copied into JAVA instances inside
Eclipse.
What happenes, iff changes take place in Eclipse. Will MagicDraw
be informed (i.e. moving a package somewhere into another).

Thanx
christian
You do not have the required permissions to view the files attached to this post.
Christian Groove
 
Posts Rating:


Return to Integrations

Who is online

Users browsing this forum: No registered users and 0 guests