Multiple selction

UML related questions and discussions

Moderator: Moderators

Re: Multiple selction

Postby justin.gliptis@baesystems.com » Mon Nov 20, 2017 6:08 am

That seems to work as long as the multiplicity of the tag is set to "unspecified" or "1". I need to be able to apply multiple tags, so I have the multiplicity set to "*". When this is the case, the tagging of multiple items does not seem to be possible. Is there a solution/workaround for this? Thanks.
justin.gliptis@baesystems.com
Forum Newbie
Forum Newbie
 
Posts: 8
Posts Rating:1
Joined: Wed May 10, 2017 9:24 am

Re: Multiple selction

Postby justin.gliptis@baesystems.com » Fri Dec 29, 2017 3:45 pm

Any update on this? Thanks.
justin.gliptis@baesystems.com
Forum Newbie
Forum Newbie
 
Posts: 8
Posts Rating:1
Joined: Wed May 10, 2017 9:24 am

Re: Multiple selction

Postby audrius.ceplinskas@nomagic.com » Tue Jan 02, 2018 1:55 am

Hello,

thank you for your answer. The "tags" problems is already fixed in 19.0 version which will be released in the coming months. As a workaround we suggest to select multiple connectors and expand tags field as in the attached pictures. It will allow to you to change value for multi-selected connectors.
Please keep us informed of your progress and accept our apologies for any inconvenience you are experiencing.

Kind regards,
No Magic Customer Support
You do not have the required permissions to view the files attached to this post.
audrius.ceplinskas@nomagic.com
Forum Newbie
Forum Newbie
 
Posts: 4
Posts Rating:0
Joined: Wed Nov 15, 2017 2:35 am

Re: Multiple selction

Postby justin.gliptis@baesystems.com » Tue Jan 02, 2018 11:34 am

I don't believe that this workaround fixes my issue. If I switch the multiplicity of the tag to anything beyond "Unspecified" or "1", then the new tag doesn't appear in the Tag tab. (I need to be able to apply more than 1 tag to each connector.) Am I missing something here?
Also, what do you mean by "The "tags" problems is already fixed in 19.0 version..."? Do you mean this multiplicity issue?
Thanks.
justin.gliptis@baesystems.com
Forum Newbie
Forum Newbie
 
Posts: 8
Posts Rating:1
Joined: Wed May 10, 2017 9:24 am

Re: Multiple selction

Postby audrius.ceplinskas@nomagic.com » Wed Jan 03, 2018 2:00 am

Hello,

thank you for the reply and explanation of the problem. It helped us to reproduce the issue. Unfortunately, when tag multiplicity e.g. is changed to *, it is impossible to enter the same tag values for selected multiple connectors. We registered the problem into our bug tracking system. Accept our apology for your inconvenience. If you have any other questions or encounter any more problems, feel free to contact us for further assistance.

Kind regards,
No Magic Customer Support
audrius.ceplinskas@nomagic.com
Forum Newbie
Forum Newbie
 
Posts: 4
Posts Rating:0
Joined: Wed Nov 15, 2017 2:35 am

Previous

Return to Software Modeling (UML)

Who is online

Users browsing this forum: No registered users and 1 guest