Issues with JBuilder6 Enterprise integration

Discussions about integrations with other 3th party tools

Moderator: Moderators

Issues with JBuilder6 Enterprise integration

Postby Erskine Williams » Tue May 07, 2002 1:44 pm

I'm trying to get a demo copy of MagicDraw UML 5.1 to integrate with
JBuilder6 Enterprise version. I was able to make it work with the JBuilder5
Professional version I have installed on the same machine. In fact, I only
tried the JB5Pro integration when the JB6Ent integration didn't work on my
first try. After testing the integration with JB5Pro to my satisfaction, I
went back to JB6Ent to try to get the integration to work, but no dice. I've
ensured that the md.properties file is correct, and that the jbuilder.config
is adding the appropriate jar files, and that the jar files exist in the
<jb6ent>/lib/ext directory. Is there something I'm missing? Is the
Enterprise edition supported?
Many thanks,
Erskine


Erskine Williams
 
Posts Rating:

Re: Issues with JBuilder6 Enterprise integration

Postby Mindaugas Ringys » Thu May 09, 2002 1:37 am

Hi Erskine,

Please try to remove log4j-core.jar file from JBuilder/lib directory.
MagicDraw uses an older version of this logging package and this causes a
problems with JBuilder6. I hope this is a case. We will solve this problem
in the MagicDraw 5.5 final version coming this June.

Let us know if this will not help.

Thanks for using MagicDraw.

--

Mindaugas Ringys
Project Leader
No Magic Lithuanian Development Center
Gedimino g. 47- 408, 3000 Kaunas, Lithuania
P.O. box 2166, LT- 3000, Kaunas, Lithuania
Phone: +370 7 324032 Fax: +370 7 320670
e-mail : mindis
WWW: http://www.nomagic.com
--
OO software design can be an appealing challenge if you have
the best UML modeling tool: http://www.magicdraw.com
"Erskine Williams" <erskine> wrote in message
news:ab9aqu$k2k$1...
> I'm trying to get a demo copy of MagicDraw UML 5.1 to integrate with
> JBuilder6 Enterprise version. I was able to make it work with the
JBuilder5
> Professional version I have installed on the same machine. In fact, I only
> tried the JB5Pro integration when the JB6Ent integration didn't work on my
> first try. After testing the integration with JB5Pro to my satisfaction, I
> went back to JB6Ent to try to get the integration to work, but no dice.
I've
> ensured that the md.properties file is correct, and that the
jbuilder.config
> is adding the appropriate jar files, and that the jar files exist in the
> <jb6ent>/lib/ext directory. Is there something I'm missing? Is the
> Enterprise edition supported?
> Many thanks,
> Erskine
>
>


Mindaugas Ringys
 
Posts Rating:

Re: Issues with JBuilder6 Enterprise integration

Postby Erskine Williams » Thu May 09, 2002 3:17 am

Yes, that was indeed the problem. The integration with JBuilder6 Enterprise
now works.
Many thanks,
Erskine


Erskine Williams
 
Posts Rating:


Return to Integrations

Who is online

Users browsing this forum: No registered users and 0 guests