Bug Report - Changing XML type breaks Automaton Macro

Other topics that do not fit in any of categories.

Moderator: Moderators

Bug Report - Changing XML type breaks Automaton Macro

Postby tiffany.hayes@avionsolutions.com » Wed Oct 28, 2020 7:14 am

I am not sure if this is just the nature of switching xml types, but here is my bug report.

Describe the Bug
If you change the project environment from xml 1.0 to xml 1.1 and then reload the project, the plugin Automaton loses functionality. More specifically, the command:

AutomatonMacroAPI.getModelData();

stops working (at least in Groovy - I have not tested it in other programming languages).

Steps to Reproduce
I have attached a sample file, but you can use any model. Simply import the Automaton plugin (com.nomagic.magicdraw.automaton.AutomatonMacroAPI) and then run a command within an opaque behavior (or evaluation expression tool) to declare a variable as "AutomatonMacroAPI.getModelData();". This will work originally. Then go to Options -> Environment and in the Save/Load tab change the XML version. Reload the project (without closing out of Cameo Systems Modeler) and when you attempt to run the code it will fail.

Expected Behavior
Since this is an environment setting in the save/load category, the expected behavior is for a reload of the project to begin working with the new xml version - not a restart of the software.

Version and Configuration
Cameo Systems Modeler 19.0 SP3
Windows 10

Additional Context
An .mdzip file is provided with a single opaque behavior to run before & after changing the xml type.
You do not have the required permissions to view the files attached to this post.
tiffany.hayes@avionsolutions.com
Forum Newbie
Forum Newbie
 
Posts: 15
Posts Rating:4
Joined: Fri Oct 02, 2020 1:11 pm

Re: Bug Report - Changing XML type breaks Automaton Macro

Postby bbu65301@bcaoo.com » Wed Nov 25, 2020 3:40 am

Same error
bbu65301@bcaoo.com
Forum Newbie
Forum Newbie
 
Posts: 2
Posts Rating:1
Joined: Sat Aug 01, 2020 2:58 am

Re: Bug Report - Changing XML type breaks Automaton Macro

Postby jake.thomas.expert@gmail.com » Thu Jun 10, 2021 1:22 am

the same one I had too
jake.thomas.expert@gmail.com
Forum Newbie
Forum Newbie
 
Posts: 2
Posts Rating:0
Joined: Thu Jun 10, 2021 1:20 am

Re: Bug Report - Changing XML type breaks Automaton Macro

Postby Uterokes » Thu Sep 30, 2021 1:17 pm

I have the same problem. Nothing special ;/
Uterokes
Forum Newbie
Forum Newbie
 
Posts: 1
Posts Rating:0
Joined: Thu Sep 30, 2021 1:12 pm
Location: Pouland
Full name: Paul Polan

Re: Bug Report - Changing XML type breaks Automaton Macro

Postby chackudd@gmail.com » Wed Nov 03, 2021 12:28 pm

has anyone found the answer?
i have same problem :roll:
chackudd@gmail.com
Forum Newbie
Forum Newbie
 
Posts: 1
Posts Rating:0
Joined: Wed Nov 03, 2021 12:26 pm
Full name: serrred


Return to Other

Who is online

Users browsing this forum: No registered users and 0 guests