Signal transmission

Systems engineering related questions and discussions.

Moderator: Moderators

Signal transmission

Postby amit.kalhapure@gmail.com » Mon Jun 28, 2021 8:32 am

Hello,

I have a question.
Suppose I want to send a signal from one port to another to switch on or switch off the component. What is the best way to do it?
1. Should I use value:boolean that changes from true <---> false?
2. Or Should I use value:integer that changes from 0 <----> 1?

Thanks,
Amit.
amit.kalhapure@gmail.com
Forum Beginner
Forum Beginner
 
Posts: 30
Posts Rating:0
Joined: Sun Aug 30, 2020 12:24 am

Re: Signal transmission

Postby saulius_p » Tue Jun 29, 2021 1:24 am

Hello Amit,

Good to talk to you! Both mentioned methods are identical and will work same good.

Please find video and sample (link in video documentation) at https://youtu.be/di7oJYtp1T8

Sincerely,
Saulius
Best regards,
Saulius Pavalkis
User avatar
saulius_p
No Magic
No Magic
 
Posts: 335
Posts Rating:14
Joined: Fri Dec 04, 2009 5:37 am
Full name: Saulius Pavalkis

Re: Signal transmission

Postby amit.kalhapure@gmail.com » Tue Jun 29, 2021 3:38 am

Thanks Saulius.
I have made a model to understand this concept. Please find the attachment.
The model works fine for true condition, but it doesn't work for false condition. .
Also I made a GUI but I don't understand how to initiate a boolean ?
Can You please help me in resolving these issues?

Thanks & Regards
Amit.
You do not have the required permissions to view the files attached to this post.
amit.kalhapure@gmail.com
Forum Beginner
Forum Beginner
 
Posts: 30
Posts Rating:0
Joined: Sun Aug 30, 2020 12:24 am

Re: Signal transmission

Postby saulius_p » Tue Jun 29, 2021 4:23 am

Hello,

Please find updated project. All works.

on off.PNG
You do not have the required permissions to view the files attached to this post.
Best regards,
Saulius Pavalkis
User avatar
saulius_p
No Magic
No Magic
 
Posts: 335
Posts Rating:14
Joined: Fri Dec 04, 2009 5:37 am
Full name: Saulius Pavalkis

Re: Signal transmission

Postby amit.kalhapure@gmail.com » Wed Jun 30, 2021 5:54 am

Thanks Saulius,
I made a small modification and attached a new block C.
But the same problem persists here. The C block doesn't get executed.

Thanks
Amit.
PIC1.jpg
You do not have the required permissions to view the files attached to this post.
amit.kalhapure@gmail.com
Forum Beginner
Forum Beginner
 
Posts: 30
Posts Rating:0
Joined: Sun Aug 30, 2020 12:24 am

Re: Signal transmission

Postby saulius_p » Wed Jun 30, 2021 7:23 am

Hello Amit,

Good to talk to you. I see that it executes. Just RPM does not update as initial RMP is not initialized - empty - no default value and formula is RPM=RPM*2, so no change to result. Please add initial value to RPM value property and it shall work.

Kind regards,
Saulius
Best regards,
Saulius Pavalkis
User avatar
saulius_p
No Magic
No Magic
 
Posts: 335
Posts Rating:14
Joined: Fri Dec 04, 2009 5:37 am
Full name: Saulius Pavalkis


Return to Model Based Systems Engineering (MBSE)

Who is online

Users browsing this forum: No registered users and 0 guests