using loop nodes with data values

Moderator: Moderators

using loop nodes with data values

Postby yshragai.firmware@gmail.com » Mon Jul 12, 2021 6:57 pm

In the attached .mdzip file, see activity MyActivity.
I have a simple conceptual loop:
Index loops from 0 to 9; on each iteration, it writes the index value to an attribute of the owning class, and increments the index.

How do I get this to be runnable by Cameo Simulation Toolkit?
In the current diagram, I used opaque actions, which I know won't do anything. (Actually, when I run the simulation, it exits as soon as it hits the loop node...)
What is the "right" way to model this so that it simulates?

Thanks!
You do not have the required permissions to view the files attached to this post.
yshragai.firmware@gmail.com
Forum Newbie
Forum Newbie
 
Posts: 17
Posts Rating:0
Joined: Fri May 07, 2021 2:35 pm

Re: using loop nodes with data values

Postby saulius_p » Wed Jul 14, 2021 5:01 am

Hello,

Good to talk to you.

Please check one of simulation samples. In 2021x, it is in SmallTestSample.mdzip (in "Structured Activity Node Tests" part). Please find it attached.

Sincerely,
Saulius

Capture.PNG
You do not have the required permissions to view the files attached to this post.
Best regards,
Saulius Pavalkis
User avatar
saulius_p
No Magic
No Magic
 
Posts: 335
Posts Rating:13
Joined: Fri Dec 04, 2009 5:37 am
Full name: Saulius Pavalkis


Return to Cameo Simulation Toolkits

Who is online

Users browsing this forum: No registered users and 0 guests