MacOS support, anyone?

Discussions about Java virtual machine, installation, and running

Moderator: Moderators

MacOS support, anyone?

Postby Immo » Thu Dec 21, 2000 4:07 am

I would like to run MagicDraw under MacOS. Besides the obvious mismatch
between Apple's latest MacOS Runtime for Java (MRJ 2.2.3), which is still
based on JDK 1.1.8, and No Magic's recommendation to use JDK 1.3 for
MagicDraw, I find another obvious problem is no way to actually start up the
application.

Apple used to have an Application Runner, but these days the MRJ comes with
just an Applet Runner that won't start up the top level object in md.jar (it
expects an HTML page with an embedded applet). I suspect that some
AppleScripting is required, but has anyone any experience of this?

Thanks in advance.

Happy Christmas.

Immo.

Immo
 
Posts Rating:

Re: MacOS support, anyone?

Postby Egidijus Vaisnora » Fri Jan 12, 2001 9:22 am

Hello Immo,

MagicDraw 3.6 and later versions is not compatible with MAC OS X so I
suggest you to wait till MagicDraw 4.0 final release which will be compatible.

Best Regards,
--
Egidijus Vaisnora
Programmer
No Magic
Gedimino g. 47- 408, 3000 Kaunas
P.O. box 2166, LT- 3000, Kaunas
Phone: +370 7 324032 Fax: +370 7 320670
e-mail: egiva
WWW: http://www.nomagic.com
--
OO software design can be an appealing challenge if you have
the best UML modeling tool: http://www.magicdraw.com


Immo Hüneke wrote:

> I would like to run MagicDraw under MacOS. Besides the obvious mismatch
> between Apple's latest MacOS Runtime for Java (MRJ 2.2.3), which is still
> based on JDK 1.1.8, and No Magic's recommendation to use JDK 1.3 for
> MagicDraw, I find another obvious problem is no way to actually start up the
> application.
>
> Apple used to have an Application Runner, but these days the MRJ comes with
> just an Applet Runner that won't start up the top level object in md.jar (it
> expects an HTML page with an embedded applet). I suspect that some
> AppleScripting is required, but has anyone any experience of this?
>
> Thanks in advance.
>
> Happy Christmas.
>
> Immo.

Egidijus Vaisnora
 
Posts Rating:

Re: MacOS support, anyone?

Postby Caitlin Bestler » Fri Feb 16, 2001 3:22 pm



Egidijus Vaisnora wrote:

> Hello Immo,
>
> MagicDraw 3.6 and later versions is not compatible with MAC OS X so I
> suggest you to wait till MagicDraw 4.0 final release which will be compatible.
>
> Best Regards,
> --
> Egidijus Vaisnora
> Programmer
> No Magic
>

Just confirming, I have 4.0 running without problems on the public Beta.
In fact, I'd say it runs better than the performance I've seen under
Linux systems and fully equivalent to the Windows JVMs.



Caitlin Bestler
 
Posts Rating:


Return to Installing and running

Who is online

Users browsing this forum: No registered users and 0 guests