Generating C# code has 0xEF 0xBB at the beginning

General discussions about code engineering

Moderator: Moderators

Generating C# code has 0xEF 0xBB at the beginning

Postby Sam Carleton » Wed Apr 08, 2009 8:05 am

I am evaluating the C# code generation peice of MagicDraw v16.0. Every
time I generate C# code, all the files start with the bytes EFh BBh, if
memory services this is some way of denoting it is or is not Unicode.
How does one turn this off?

Sam (user ID #493153)
Sam Carleton
 
Posts Rating:

Re: Generating C# code has 0xEF 0xBB at the beginning

Postby Thanadee U. » Thu Apr 09, 2009 6:30 am

Dear Sam,

Could you give me the MagicDraw save file(.mdzip and also .mdr) for
generating your attached code? And please give me the information of
your environment too. We will investigate the problem as soon as possible.

Best regards,

Arnon L.
--
Customer Support Engineer
No Magic Asia Ltd.
(Asian Software Development Center)
719 KPN Tower, 22nd Floor, Huaykwang,
Bangkapi, Bangkok 10310 Thailand
Phone: + 66 2717-0250
Fax: + 662 717-0251
Email: support
<mailbox:///D%7C/E/Back_C_for_Pipat/Thunderbird/Profiles/xmt04imq.default/Mail/mail.nomagicasia.com/Inbox?number=-2046093092>

nntp://news.nomagic.com/nomagic.products.magicdrawuml.codeengineering
wrote:
> I am evaluating the C# code generation peice of MagicDraw v16.0.
> Every time I generate C# code, all the files start with the bytes EFh
> BBh, if memory services this is some way of denoting it is or is not
> Unicode. How does one turn this off?
>
> Sam (user ID #493153)
>
>

You do not have the required permissions to view the files attached to this post.
Thanadee U.
 
Posts Rating:

Re: Generating C# code has 0xEF 0xBB at the beginning

Postby mvinca-tsi » Tue Jul 22, 2014 11:33 am

I am also having this issue. Was there any resolution?
mvinca-tsi
Forum Beginner
Forum Beginner
 
Posts: 29
Posts Rating:1
Joined: Wed Apr 23, 2014 7:03 am
Full name: Michael Vinca

Re: Generating C# code has 0xEF 0xBB at the beginning

Postby thanadee » Wed Jul 23, 2014 4:37 am

Hi,

Can you please open MagicDraw and change the default encoding in "Options->Project->Code Engineering->Default Encoding" to something else such as "US-ASCII" and then generate again?

Best regards,

Thanadee U.
Support Engineer
thanadee
No Magic
No Magic
 
Posts: 5
Posts Rating:0
Joined: Wed Jan 06, 2010 12:54 am


Return to Code engineering

Who is online

Users browsing this forum: No registered users and 1 guest