signals are being removed before being consumed

Moderator: Moderators

Re: signals are being removed before being consumed

Postby kerry.wagner@peopletec.com » Fri Aug 06, 2021 2:03 pm

I am getting the same error when in a model of a system with system elements sending signals in a sequence diagram.
I'm having the same Accept Event Action for a system element for a signal that is sent to the system element twice.
It works perfectly if the Accept Event Action for the signal is activated twice by receiving the same signal twice with different data.
But if I want to add a second Accept Event Action in the Activity Diagram for a different message (signal) reception then adding the second Accept Event Action for the new message causes the initial Accept Event Action to terminate after receiving the first of the two messages.
How do I get the initial Accept Event Action handler of my initial message to stay active to receive the second occurrence of the same message?
Seems like an error in the tool.
The literature says that "In addition, an Accept Event Action with no incoming edges remains enabled after it accepts an Event"
But the documentation (User Guide) NOWHERE says what "no incoming edges" means or how to configure the Accept Event Action to stay enabled.
Somebody PLEASE help me with this error!!
kerry.wagner@peopletec.com
Forum Newbie
Forum Newbie
 
Posts: 2
Posts Rating:0
Joined: Fri Aug 06, 2021 1:56 pm

Re: signals are being removed before being consumed

Postby saulius_p » Tue Aug 17, 2021 10:26 am

Hello,

Good to talk to you. Please find instructions and sample in video description at: https://youtu.be/ketPkFjGyWE

Let us know if problem still persist. Sample model would help.

Kind regards,
Saulius
Best regards,
Saulius Pavalkis
User avatar
saulius_p
No Magic
No Magic
 
Posts: 335
Posts Rating:14
Joined: Fri Dec 04, 2009 5:37 am
Full name: Saulius Pavalkis

Previous

Return to Cameo Simulation Toolkits

Who is online

Users browsing this forum: No registered users and 0 guests