Strings Not being read properly during simulation

Moderator: Moderators

Strings Not being read properly during simulation

Postby ohs18 » Tue Mar 02, 2021 12:52 pm


I am running a simulation where I run an activity diagram that passes a block's value properties into a matlab function called by an opaque behavior. Most of the value properties I am passing are integers, but I am also trying to pass a couple string value properties as well. When I run the simulation, I can see the Name and the default value properly display in the variables pane. For example, I have a value property called "location" with a default value of "United States" which is of type string. However, when I type the the variable name in the command window with Matlab as the language, it displays as "[]", which I am assuming is an empty array. I'm not sure why this is happening or how to fix it, so any help is greatly appreciated.

Forum Newbie
Forum Newbie
Posts: 17
Posts Rating:1
Joined: Wed Jan 20, 2021 7:08 pm

Return to Cameo Simulation Toolkits

Who is online

Users browsing this forum: No registered users and 2 guests