Subgroups NOT showing up in Properties tab

Discussions about Domain Specific Language customizations

Moderator: Moderators

Subgroups NOT showing up in Properties tab

Postby fhuy » Wed Mar 07, 2018 6:33 pm

I'm wondering if someone could assist me please. I have create a stereotype and customization and have applied it. It all works fine except the "subgroups" of my customization does not show up on the "properties" tab. I have added a few reqmts to demonstrate. Req 5 has the stereotype applied (i.e. AnalysisTypes) and when you go into the spec for that reqmt [see img#1] you can see that the reqmt has the new tab (i.e. requirement analysis) and the subgroups with each of their attributes. However if you look at the properties tab for that same reqmt [see img#2], it only shows the "group" without the "subgroup". Ironically, the attributes that is reflected in the subgroups in the requirement spec window are shown in the "Elements Tab" [see img#3]. I've been following the Profiling & DSL user manual and on pg 79 is a good example of what I'm attempted to do. Any assistance would be appreciated
You do not have the required permissions to view the files attached to this post.
fhuy
Forum Newbie
Forum Newbie
 
Posts: 5
Posts Rating:0
Joined: Thu Dec 01, 2016 9:40 am

Re: Subgroups NOT showing up in Properties tab

Postby donatas.mazeika@nomagic.com » Wed Mar 14, 2018 9:39 am

Hello,

Thank you for showing this situation. We've marked this issue as a bug and it will be fixed in the upcoming version of MagicDraw.

Have a nice day,
Donatas Mazeika
donatas.mazeika@nomagic.com
Forum Expert
Forum Expert
 
Posts: 121
Posts Rating:17
Joined: Tue Apr 21, 2015 12:30 am


Return to DSL

Who is online

Users browsing this forum: No registered users and 0 guests

cron