Trade Study error

Discussions about ParaMagic functionalities

Moderator: Moderators

Trade Study error

Postby pedrospada » Tue Jun 28, 2016 6:11 pm

I’m trying to run a few trade studies in my sysml model using the functionality provided by Paramagic plugin.

I configured an Excel spreadsheet for such, and made sure I could read, and write, values from it. I also verified that my instance model could be successfuly solved in Paramagic browser, which was, everytime I clicked “solve”.

But whenever I set up and run a Trade Study (right click instance model -> Paramagic -> Trade Study -> setup/Run), instead of seeing the normal progress bar, as shown below:


Paramagic immediatly freezes in the following screen:


And stays there forever. No "Running Scenario" numeric progress is shown, nor values are written in the spreadsheet. If the cancel button is hit, then an error is produced. The only way to stop the execution is to exit MagicDraw

I tried to reproduce this error with a smaller sysml model, without success (this time the trade studies ran ok). Which leads me to the conclusion that there must be something wrong with my model’s parametric equations. But since my instance model, as mentioned before, could be solved without any trouble, I don't know what could be going wrong.

Does anybody know if the parametric constraints should be arranged in a specific way in order to successfuly run Paramagic’s Excel Trade Studies? Has anyone experienced a similar situation?
You do not have the required permissions to view the files attached to this post.
Forum Newbie
Forum Newbie
Posts: 3
Posts Rating:0
Joined: Thu Jun 23, 2016 5:25 pm

Return to ParaMagic

Who is online

Users browsing this forum: No registered users and 0 guests