Updating UML model very slow with Eclipse

Discussions about integrations with other 3th party tools

Moderator: Moderators

Updating UML model very slow with Eclipse

Postby Andrew McVeigh » Wed May 22, 2002 4:53 pm

Hi,

I have been trying out the eclipse integration with a moderately sized
project (about 200 classes) and updating the model from eclipse is very
slow. It takes about 10 seconds per class. In JBuilder it was very fast,
but I'd much rather use eclipse than JBuilder. Is there any way to speed
this process up?

A couple of other points:

1) the magidraw L&F seems to be stuck on Metal for the integrated MD5.5. Is
there any way to change this?

2) a suggestion: could you add a flag so that methods and attributes don't
automatically get added to a symbol when updating? i.e. if I have a symbole
of Car on the screen with the method "drive()" and I add a "stop()" method
in eclipse and update the model, I would like to have the choice about
whether the "stop()" method gets automatically added to the diagram(s). At
the moment, it is a problem, as I update my model and often find that the
diagrams have become completely messy due to added methods and attributes.

Cheers,
Andrew McVeigh
London, UK


Andrew McVeigh
 
Posts Rating:

Re: Updating UML model very slow with Eclipse

Postby Mindaugas Ringys » Tue Jun 04, 2002 6:52 am

Hi Andrew,

We will try to improve performance in final MagicDraw 5.5 release.

You will be able to choose L&F in final 5.5 also.

I will put your last suggestion in our future functionality list.

Thanks for your feedback.

--

Mindaugas Ringys
Project Leader
No Magic Lithuanian Development Center
Gedimino g. 47- 408, 3000 Kaunas, Lithuania
P.O. box 2166, LT- 3000, Kaunas, Lithuania
Phone: +370 37 324032 Fax: +370 37 320670
e-mail : mindis
WWW: http://www.nomagic.com
--
OO software design can be an appealing challenge if you have
the best UML modeling tool: http://www.magicdraw.com
"Andrew McVeigh" <andrewmcveigh> wrote in message
news:ach6va$inf$1...
> Hi,
>
> I have been trying out the eclipse integration with a moderately sized
> project (about 200 classes) and updating the model from eclipse is very
> slow. It takes about 10 seconds per class. In JBuilder it was very fast,
> but I'd much rather use eclipse than JBuilder. Is there any way to speed
> this process up?
>
> A couple of other points:
>
> 1) the magidraw L&F seems to be stuck on Metal for the integrated MD5.5.
Is
> there any way to change this?
>
> 2) a suggestion: could you add a flag so that methods and attributes
don't
> automatically get added to a symbol when updating? i.e. if I have a
symbole
> of Car on the screen with the method "drive()" and I add a "stop()" method
> in eclipse and update the model, I would like to have the choice about
> whether the "stop()" method gets automatically added to the diagram(s).
At
> the moment, it is a problem, as I update my model and often find that the
> diagrams have become completely messy due to added methods and attributes.
>
> Cheers,
> Andrew McVeigh
> London, UK
>
>


Mindaugas Ringys
 
Posts Rating:


Return to Integrations

Who is online

Users browsing this forum: No registered users and 1 guest