Page 1 of 1

Cameo Systems Modeler 18.5: Java Error

PostPosted: Thu Jun 15, 2017 7:21 am
by cg7aa
Hi,

I'm not sure if this is the right forum for my question so please forgive me if it's not; I'm trying to follow the web tutorial here: https://www.youtube.com/watch?v=9RFKoTUiQ60

Whenever I execute the timer simulation I get the following error messages:

00:00:00,000 : **** Activity Tick is initialized. ****
00:00:00,000 : **** Activity Tick is started! ****
00:00:00,939 ERROR: Cannot evaluate Opaque Action: org.mozilla.javascript.EcmaError: ReferenceError: "time" is not defined. (<Unknown source>#1) in <Unknown source> at line number 1 expression body: time = time+1 00:00:01,248 : **** Activity Tick execution is terminated. ****

Any help would be greatly appreciated. I've already experimented with changing the location of Java in the properties file and I can't find any solutions online.

Regards
Dan

Re: Cameo Systems Modeler 18.5: Java Error

PostPosted: Sun Jun 18, 2017 8:32 pm
by arnon_l
Dan,

Please make sure that "time" property has been defined in your model.

Or you can send me the model to check.

Regards,

Re: Cameo Systems Modeler 18.5: Java Error

PostPosted: Tue Jun 20, 2017 2:40 pm
by piccolocanadesevolante@gmail.com
arnon_l wrote:Dan,

Please make sure that "time" property has been defined in your model.

Or you can send me the model to check.

Regards,


Thanks very much for your offer to help. I've attached the file. I defined time as demonstrated in the youtube tutorial, maybe I made a mistake in the definition.

Re: Cameo Systems Modeler 18.5: Java Error

PostPosted: Wed Jun 28, 2017 9:31 am
by piccolocanadesevolante@gmail.com
Problem solved; it seems the value property 'time' was in the wrong part of the containment tree.