Page 1 of 1

Cameo Systems Modeler does not start

PostPosted: Sat Sep 12, 2015 3:26 pm
by enwude@umd.edu
Hi,

I installed Cameo Systems Modeler 18.2 on my system but keep getting the following error when i try to launch it:

Cache error occurred.
Restart all running MagicDraw applications. On restart MagicDraw will rebuild all caches.

I'm running windows 10 with 16GB RAM.
Was I meant to install this as an add-on to MagicDraw or can I install it as a standalone software? I do not have MagicDraw installed on the system.

Thanks.

Re: Cameo Systems Modeler does not start

PostPosted: Tue Sep 15, 2015 4:57 am
by reggre
Hello,

Thank you for the issue report. This message "Restart all running MagicDraw applications. On restart MagicDraw will rebuild all caches." is common message for MagicDraw, CSM and other our products. You do not need to install MagicDraw.
To resolve this issue please these steps:
1. Delete CSM configuration files from userhome directory which can be found in C:\Users\<username>\AppData\Local\.cameo.systems.modeler\<Cameo Systems Modeler version number>.All files inside of catalog "Cameo Systems Modeler version number"
2. Reinstall CSM and try to start.

If you will get the same error please send us csm.log file from C:\Users\<username>\AppData\Local\.cameo.systems.modeler\<Cameo Systems Modeler version number> for the further investigation.

Please inform us about your progress.

Please accept our apologies for your inconvenience.

Kind regards,
No Magic Customer Support

Re: Cameo Systems Modeler does not start

PostPosted: Tue Sep 15, 2015 6:58 am
by enwude@umd.edu
Hey,

Thanks for your reply. Tried the procedure you outlined but still got the same error so I have included the csm log file with the message as requested.

Regards,

Ejike

Re: Cameo Systems Modeler does not start

PostPosted: Tue Sep 15, 2015 7:26 am
by reggre
Hello,

Please try the other way:
1. Close CSM
2. Delete CSM configuration files from userhome directory.
3. Open csm.properties file ( which can be found in with <CSM installation folder>/bin catalog) any text ediror
4. add -Dcom.sun.media.imageio.disableCodecLib=true option into JAVA_ARGS line
for example:
JAVA_ARGS=-Xmx4000M -XX\:PermSize\=60M -XX\:MaxPermSize\=200M -DLOCALCONFIG\=true -splash\:data/splash.png -Dmd.class.path\=$java.class.path -Dcom.nomagic.osgi.config.dir\=configuration -Desi.system.config\=data/application.conf -Dlogback.configurationFile\=data/logback.xml -Xss1024K -Dcom.sun.media.imageio.disableCodecLib=true

5. Save all changes.
6. Start CSM again.

Please inform us about your progress.

Please accept our apologies for your inconvenience.

Kind regards,
No Magic Customer Support

Re: Cameo Systems Modeler does not start

PostPosted: Tue Sep 15, 2015 10:13 am
by enwude@umd.edu
Hey,

Thanks again for your assistance. The issue got resolved after I entered the line of code you specified and was able to start the program. Really appreciate the help.

Thanks again.

Regards

Ejike

Re: Cameo Systems Modeler does not start

PostPosted: Wed Sep 16, 2015 12:26 am
by reggre
Hello,

Thank you for informing us about your status. We are excited that you can successfully continue in your work.

Best Regards,
No Magic Customer Support