WSAD and MD on Linux

Discussions about integrations with other 3th party tools

Moderator: Moderators

WSAD and MD on Linux

Postby Raffael Herzog » Tue Jul 09, 2002 9:30 am

Hi,


I understand that the Eclipse integration plug-in is written
for Eclipse 2.0, we'll have to wait for WSAD5. But it's IMHO
important that the integration works with Eclipse/Motif, as
IBM does not provide a GTK version (and *if* they would, it
would probably be as unusable as Eclipse/GTK).

Are there any plans in that direction?


cu,

Raffi


--
Neu im Usenet? Fragen? http://www.use-net.ch/usenet_intro_de.html

My opinions may have changed, but not the fact, that I'm right!
Raffael Herzog - herzog - http://www.raffael.ch - ICQ #67961355
Raffael Herzog
 
Posts Rating:

Re: WSAD and MD on Linux

Postby Andrius Strazdauskas » Wed Jul 10, 2002 8:14 am

Raffi,

thanks for the suggestion.
We will consider it.

Best regards,
--
Andrius Strazdauskas
Product Research and Development Manager
No Magic Lithuanian Development Center
P.O. box 2166, LT-3000, Kaunas
Phone: +370-37-225328, Fax +370-37-320670
E-mail: andriuss
WWW: http://www.nomagic.com


Andrius Strazdauskas
 
Posts Rating:

Re: WSAD and MD on Linux

Postby Christian Groove » Tue Jul 16, 2002 3:06 pm

Raffael Herzog wrote:

> Hi,
>
>
> I understand that the Eclipse integration plug-in is written
> for Eclipse 2.0, we'll have to wait for WSAD5. But it's IMHO

What is ESAD5 ??

> important that the integration works with Eclipse/Motif, as
> IBM does not provide a GTK version (and *if* they would, it
> would probably be as unusable as Eclipse/GTK).


The problem results in the descision of the IBM/Eclipse developpers
to use gtk2.0 that is actually rarely supported. This situation may
change with forecoming Linux-Distributions, that will have support
for gtk2.0/Gnome.
The problem now looks like to be an incompatibility with the
motif-verisions, because Eclispe-2 ships it own motif-library,
that is incompatible with the commonly installed motif/lesstif
libs on UNIX. On this ground you should have to set the
LD_LIBRARY_PATH to the installation directory, in order to prevent
Eclipse to load Lestif of a Motif-1.2 versions.

It is not clear to me, but when i call MagicDraw out of Eclipse,
i receive an error, that reminds me of the situation with an
unset LD_LIBRARY_PATH variable.

Groovy

>
> Are there any plans in that direction?
>
>
> cu,
>
> Raffi
>
>

Christian Groove
 
Posts Rating:

Re: WSAD and MD on Linux

Postby Raffael Herzog » Tue Jul 16, 2002 4:12 pm

Hi Christian,

Christian Groove wrote:

> Raffael Herzog wrote:
>
> > I understand that the Eclipse integration plug-in is written
> > for Eclipse 2.0, we'll have to wait for WSAD5. But it's IMHO
>
> What is ESAD5 ??

Well, I now have to use WDAD 4.0.3. The next version will be
WSAD 5.0 and this one will be based on Eclipse 2. This is
WSAD5.


> > important that the integration works with Eclipse/Motif, as
> > IBM does not provide a GTK version (and *if* they would, it
> > would probably be as unusable as Eclipse/GTK).
>
> The problem results in the descision of the IBM/Eclipse developpers
> to use gtk2.0 that is actually rarely supported.

$ apt-get install libgtk2

...done. Unfortunately, the only usable Linux-version of
Eclipse is the Motif-version. WSAD isn't even available for
GTK.


> The problem now looks like to be an incompatibility with the
> motif-verisions, because Eclispe-2 ships it own motif-library,
> that is incompatible with the commonly installed motif/lesstif
> libs on UNIX.

Eclipse/Motif ships with OpenMotif 2.1 which is installed as
Debian package on my system. There's no version clash.


cu,

Raffi


--
Neu im Usenet? Fragen? http://www.use-net.ch/usenet_intro_de.html

My opinions may have changed, but not the fact, that I'm right!
Raffael Herzog - herzog - http://www.raffael.ch - ICQ #67961355
Raffael Herzog
 
Posts Rating:


Return to Integrations

Who is online

Users browsing this forum: No registered users and 1 guest